Технический форум Проблемы с МТА
Tab 28.05.2013 в 19:46

Пользователь

Репутация: 1 бал.

Замечания: 0 бал.

Пишем сюда проблемы и вместе их решаем.
johnnycraft 28.05.2013 в 19:48

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Такой вопрос: Можно ли "прилепить" свою карту к карте гташки ?допустим я сделал трек,можно ли его поставить на пляж санта мария как-то ?
BlackFan 29.05.2013 в 05:43

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Уважаемые, огромная просьба помочь убрать эти ошибки и предупреждения, которые вылезают в консоли чуть ли не каждые несколько секунд. На сервере установлен мод DayZ, так же установлены новые машины и оружие. Больше ничего нет.

WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1133 Bad 'element' pointer @ 'giveWeapon'(1)
WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1153 Bad argument @ 'setElementData' [Expected element at argument 1]
WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1133 Bad 'element' pointer @ 'giveWeapon'(1)
WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1153 Bad argument @ 'setElementData' [Expected element at argument 1]
WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1153 Bad argument @ 'setElementData' [Expected element at argument 1]
WARNING: [DayZ-MTA]/slothbot/sbserver.lua:1133 Bad 'element' pointer @ 'giveWeapon'(1)
ERROR: ?:0: attempt to perform arithmetic on a boolean value ERROR: ?:0: attempt to perform arithmetic on a boolean value
WARNING: Bad argument @ 'destroyElement' [Expected element at argument 1, got boolean] ?


P.S. Только что выяснил что эти ошибки начинают выскакивать только тогда - когда игрок садится в машину. Вот как только он сел - в консоли появляются эти ошибки.
RaceR 29.05.2013 в 12:07

Администратор

Репутация: 1195 бал.

Замечания: 0 бал.

johnnycraft, Да можно, раздел Wiki => замена объектов.
RaceR 29.05.2013 в 12:09

Администратор

Репутация: 1195 бал.

Замечания: 0 бал.

BlackFan, Сами ошибки как то влияют на игровой процесс?
6yxou45 29.05.2013 в 17:04

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

нет просто они как бы мне не нравиться что в консоли какие то ошиьки выдает вот эти

[2013-05-29 21:01:55] WARNING: [DayZ-MTA]/slothbot/sbserver.lua:112: Bad argument @ 'getElementPosition' [Expected element at argument 1, got nil]
[2013-05-29 21:01:57] WARNING: Bad argument @ 'destroyElement' [Expected element at argument 1, got boolean]
RaceR 29.05.2013 в 17:36

Администратор

Репутация: 1195 бал.

Замечания: 0 бал.

6yxou45, Ну во первых это не ошибки, а предупреждения.
6yxou45 29.05.2013 в 18:05

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

и о чем они предупреждают можно узнать?
RaceR 29.05.2013 в 18:10

Администратор

Репутация: 1195 бал.

Замечания: 0 бал.

6yxou45, О неправильных логических аргументах, типа true, false.
Molo 30.05.2013 в 07:40

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Помогите мне пожалуйста!Я сделал ворота,всё как описанно в Wiki:

local gate = createObject(988, 1769, 622.5, 9.8000001907349, 0, 0, 76)
function MoveGate (cmd1)
moveObject(gate, 1000, 0, 0, 0)
outputChatBox("/opengate.", source)
end

addCommandHandler("OpenGate",MoveGate)

function MoveGateBack (cmd2)
moveObject(gate, 1000, 1768,622.5, 9.8000001907349)
outputChatBox("/closegate.", source)
end

addCommandHandler("CloseGate",MoveGateBack)


Я только одно не понял куда и какую вставить команду чтобы они открывались! :) ВСЁ Я ПОНЯЛ!Извеняюсь за флуд!
BlackFan 30.05.2013 в 08:25

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Molo, Я только одно не понял куда и какую вставить команду чтобы они открывались!


outputChatBox("/opengate.", source)

открыть ворота
и
outputChatBox("/closegate.", source)

закрыть ворота
Molo 30.05.2013 в 08:55

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Ребята!Поставил музыку на сервер как тут пишется http://www.mta-resource.ru/musicmaps.html ,всё работает,всё чётко вообщем,НО есть одно "НО"!МУЗЫКА сто раз повторяется,как сделать чтобы она проигрывала только один раз?
MarkPayneNYPD 01.06.2013 в 11:31

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Всем привет, Проблема с предыдущего форума так и не решилась, не могу поставить свою карту Вот лог сервера:
[15:11:44] ERROR: mapmanagermapmanager_exports.lua:68: mapmanager: Map '[MOD]zmad' is not compatible with 'play'.
Карту заархивировал и положил в ресурсы, но она не запускается. Видимо карту нужно добавить непосредственно в гейммод, но я не знаю какой выбрать Хмм мне нужно чтобы персонажи сохранялись, карта не менялась, что то типа РП
AdminPlay 01.06.2013 в 11:31

Проверенный

Репутация: 44 бал.

Замечания: 0 бал.

MarkPayneNYPD, ты переименовал ресурс в название login_panel?
MarkPayneNYPD 02.06.2013 в 19:05

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

AdminPlay, проблема решилась, я в коде напортачил во время фикса. Добавлено (02.06.2013, 22:06) Сделал все как в ВИКИ, чтобы ворота airport gates 980 (2) открывались по команде Вот скрипт: client.lua
local gate = createObject(980, -2673.6999511719, 2143.5, 57.200000762939, 0, 0, 0)  function MoveGate (cmd1)  moveObject(gate, 1000, 0, 0, 0)  outputChatBox("/open", source)  end  addCommandHandler("OpenGate",MoveGate)  function MoveGateBack (cmd2)  moveObject(gate, 1000, -2673.6999511719, 2143.5, 64)  outputChatBox("/close", source)  end  addCommandHandler("CloseGate",MoveGateBack)
meta.xml
<meta>  <info type="script" name="Basemarok" author="MarkPayneNYPD" version="1.0.0" >  <script src="client.lua" type="client" >  </meta>
Но ворота не открываются, никак не могу понять в чем проблема. Буду благодарен за помощь
RaceR 02.06.2013 в 19:24

Администратор

Репутация: 1195 бал.

Замечания: 0 бал.

MarkPayneNYPD, Код скрипта всегда прячь в тег "Код".Не работает потому что объекты которые поставлены на карте через IPL двигать нельзя.
Dokar74 04.06.2013 в 05:13

Проверенный

Репутация: 8 бал.

Замечания: 2 бал.

Добрый день! Помогите пожалуйста,у меня всё та же ошибка с транспортом!Он не спавнится.Но я зделал по своему,зашёл в MapEditor и расставил транспорт!Когда я сохраняю карту с транспортом и загружаю в DayZ.Но когда я вижу этот транспорт и подхожу к ниму,то у меня не высвечивается меню транспорта.Помогите решить проблему(
live7up 04.06.2013 в 09:31

Проверенный

Репутация: 8 бал.

Замечания: 0 бал.

Dokar74Добрый день! Помогите пожалуйста,у меня всё та же ошибка с транспортом!Он не спавнится.Но я зделал по своему,зашёл в MapEditor и расставил транспорт!Когда я сохраняю карту с транспортом и загружаю в DayZ.Но когда я вижу этот транспорт и подхожу к ниму,то у меня не высвечивается меню транспорта.Помогите решить проблему(
Добавлять на карту через мап эдитор технику нельзя она тупо не будет работать, т.к техника не прописала в скриптах dayz
Molo 05.06.2013 в 06:28

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Всем привет!Это снова я!Извеняюсь за свои постоянные вопросы тут,но я всё пытаюсь разобраться....На этот раз такое дело: [ссылка удалена] Тут вроде как всё понятно,сделал,вставил координаты,закинул на серв,ошибок нету,но не пашет,ВООБЩЕМ,можете кинуть мне пример вашего интерьера,и какие и сколько должно быть файлов в архиве..БЛАГОДАРЮ за ВНИМАНИЕ!
hotab 07.06.2013 в 16:08

Пользователь

Репутация: 0 бал.

Замечания: 0 бал.

Помогите я зашол на 2IP и взял от туда IP и всктавил в ServerIP и при запуске аот что вылетает!
Войдие или зарегистрируйтесь что бы написать сообщение